Ibus -- falta pacote pra funcionar com apps GTK!

Assuntos gerais relacionados ao tema KDE.

Ibus -- falta pacote pra funcionar com apps GTK!

Mensagempor André Luiz » Qui Mar 06, 2014 9:39 am

Pessoal,
Sou poliglota, e faço questão de usar os recursos de 'input' mulitlíngue; o Input Method padrão do KDE (?) no Mageia é o Ibus -- embora seja possível usar outros, como o SCIM (Smart Common Input Method) -- mas a instalação não 'chama' todos os pacotes necessários para que o Ibus funcione com todas os aplicativos... Mais especificamente: em aplicativos Gtk, como Firefox, Thunderbird, etc, o Ibus não funciona direito, a não ser que se instale manualmente alguns pacotes a mais:
Código: Selecionar todos
ibus-gtk
ibus-gkt3
ibus-ui-gtk3
plasma-applet-kimpanel-backend-ibus

Atualizei meu desktop para o Mageia 4 c/ KDE 4.11 nesse último final de semana e, para minha decepção, descobri que não tem pacote 'plasma-applet-kimpanel-backend-ibus' atualizado (versão 4.11) nos repositórios da versão... Só encontrei para o Mageia 3 ( .../core/updates/plasma-applet-kimpanel-backend-ibus-4.10.5-1.1.mga3.x86_64.rpm )... Estranho , né? :(
Posso usar essa versão antiga na boa? Ou terei que fazer um 'downgrade' de não sei quantos pacotes (o rpmdrake informa que ele tem como dependência o pacote 'plasma-applet-kimpanel'; aí eu instalei esse pacote via CCM, mas chamou como dependência outros dois pacotes, inclusive um 'plasma-applet-kimpanel-backend-scim' ?!... Convenhamos, uma 'bola fora'; os pacotes atualizados para SCIM já estão nos repositórios, mas os do Ibus não...!)

Trocar de IM não é negócio; já usei (ou melhor, tentei usar...) o SCIM antes, e ele é muito pior de instalar -- depende de mais pacotes ainda pra rodar direito seja com Qt ou Gtk, e não há informação coerente sobre isso... Parece que esse projeto caducou, daí a mudança para o Ibus.

Fico no aguardo. Grato!

Abraços
Avatar do usuário
André Luiz
Colaborador Intermediario Mageia
Colaborador Intermediario Mageia
 
Mensagens: 88
Registrado em: Dom Abr 21, 2013 8:43 pm

Re: Ibus -- falta pacote pra funcionar com apps GTK!

Mensagempor macxi » Qui Mar 06, 2014 10:20 am

Não entendo deste tema, apenas achei um item na Errata da Mageia 4 sobre internacionalização que pode estar relacionada a este assunto:

https://wiki.mageia.org/en/Mageia_4_Err ... nalization
Avatar do usuário
macxi
Suporte Wiki Mageia Brasil
Suporte Wiki Mageia Brasil
 
Mensagens: 1547
Registrado em: Qua Abr 17, 2013 10:09 pm

Re: Ibus -- falta pacote pra funcionar com apps GTK!

Mensagempor will » Qui Mar 06, 2014 1:12 pm

Esses projetos pouco conhecidos estao meio abandonados :(
O SCIM sei qu é usado para escrever japonés, más o ibus sempre tem algúm pocote faltando para funcionar, ou precisa de modificaçao nos archivos de configuraçao.
nosXw
Imagem
Avatar do usuário
will
Super Mago Mageia
Super Mago Mageia
 
Mensagens: 740
Registrado em: Qui Mai 02, 2013 10:39 pm

Re: Ibus -- falta pacote pra funcionar com apps GTK!

Mensagempor André Luiz » Qui Mar 13, 2014 9:41 am

Obrigado, macxi.
É, exatamente o problema que enfrento... (bem, quem manda não ler a Errata 'TODA' antes de instalar a nova versão?! :mrgreen: )
Bem, o 'workaround' (nossa popular "gambiarra"!) está lá descrita; não vou repetir o conteúdo porque tem caracteres que o servidor não está aceitando (deve ser o problema descrito no tópico http://mageiadobrasil.com.br/forum/viewtopic.php?f=4&t=580-- vá entender... Estou há dias tentando postar e não conseguia por isso!
Mas não funcionou de todo não! Para thunderbird e leafpad (um clone do Notepad do Windows, em Gtk) deu certo, mas no firefox não! E ainda por cima o menu de preferências do próprio ibus ficou inoperante! Tudo isso é mencionado no relato do bug 8731 (https://bugs.mageia.org/show_bug.cgi?id=8731), que primeiro descreveu esse 'fenômeno"... Vou tentar outras 'gambiarras' com esse export até acertar.

will,
Tanto o Ibus quanto o SCIM servem para input CJK (Chinese, Japanese, Korean) e outros idiomas asiáticos, para os quais não basta trocar/adicionar layout de teclado (caso do árabe); como são recursos que "nem todo mundo usa" (quantos usuários ocidentais também lêem & escrevem em idiomas de escrita não latina?...), os bugs acabam não sendo descobertos, e o ritmo de desenvolvimento fica comprometido... Eu preciso aprender a escrever código também, pra ver se contribuo mais!! :geek:

Um 'desabafo': seria bom se houvesse 'um pouco menos de diversidade' nessa questão de frameworks -- é um saco ter aplicativo que funciona em Gtk, outro em Qt , e sabe-se lá o quê mais, e a gente tendo que acrescentar um monte de libs disso e daquilo pra que tudo funcione...! E rezando pra que as coisas continuem funcionando quando atualizamos o sistema!... :x

Quando conseguir fazer tudo funcionar, darei o problema como resolvido!


Abraços a todos!
Avatar do usuário
André Luiz
Colaborador Intermediario Mageia
Colaborador Intermediario Mageia
 
Mensagens: 88
Registrado em: Dom Abr 21, 2013 8:43 pm


Voltar para KDE

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes

cron