Wine não instala direito no Mageia3 64 bits![RESOLVIDO]

Assuntos relacionados com jogos e entretenimento para o mageia.

Wine não instala direito no Mageia3 64 bits![RESOLVIDO]

Mensagempor André Luiz » Sex Nov 15, 2013 6:06 pm

Pessoal,
Resolvi dar 'nova chance' ao Wine, e tentei instalá-lo em meu desktop Mageia 3 64 bits; mas, estranhamente, o MCC bloqueia a instalação do pacote wine32 (necessário para executar aplicativos de 32 bits do Windows), sem mais explicações! Ele não diz se falta isso ou aquilo de dependências... apenas não deixa instalar! O mesmo acontece se tento instalar a pacote wine i586... A versão do Wine disponível nos repositórios é a 1.5.7 ... Isso teria a ver com quais repositórios estão habilitados?


Grato!
Anexos
Mídias.png
MMC - Gerenciador de mídias
Editado pela última vez por André Luiz em Dom Nov 24, 2013 4:27 pm, em um total de 1 vez.
Avatar do usuário
André Luiz
Colaborador Intermediario Mageia
Colaborador Intermediario Mageia
 
Mensagens: 88
Registrado em: Dom Abr 21, 2013 8:43 pm

Re: Wine não instala direito no Mageia 5 64 bits!

Mensagempor geraldow » Sex Nov 15, 2013 6:39 pm

Tente instalar pelo terminal pra ver se ele retorna alguma mensagem de erro.

É só abrir o terminal, entrar como root (su + senha) e mandar instalar (urpmi wine).
Veja se ele retorna algo.

Abraço!
geraldow
Colaborador Senior Mageia
Colaborador Senior Mageia
 
Mensagens: 226
Registrado em: Dom Abr 21, 2013 7:11 pm

Re: Wine não instala direito no Mageia3 64 bits!

Mensagempor macxi » Sex Nov 15, 2013 8:24 pm

André Luiz escreveu: (...). Isso teria a ver com quais repositórios estão habilitados?
Grato!


André,
Na imagem q vc disponibilizou, todos os repositórios estão habilitados, mas o correto, seria habilitar só algumas mídias. Dá um olhada no Wiki Mageia: Mídia padrão habilitada automaticamente e mídia opcional - Mageia (64 bit)
Avatar do usuário
macxi
Suporte Wiki Mageia Brasil
Suporte Wiki Mageia Brasil
 
Mensagens: 1535
Registrado em: Qua Abr 17, 2013 10:09 pm

Re: Wine não instala direito no Mageia3 64 bits!

Mensagempor André Luiz » Sáb Nov 16, 2013 11:38 am

Ok, revisei quais repositórios habilitar, conforme o sugerido (a gente fica com mania de pegar tudo, 'até a pia da cozinha!")
Agora minhas mídias estão assim (anexo) -- tá legal assim?

Mas, como recuperar a instalação dos pacotes relativos ao wine? Só desabilitar as mídias, em si, não resolve... Tem alguma maneira de identificar exatamente os pacotes que estão em conflito e 'purgá-los' ou algo assim?... (claro que deve ter, via terminal! Eu é que ainda tenho muito a aprender!!)
Valeu!
Anexos
Mídias_revisto.png
Editado pela última vez por André Luiz em Sáb Dez 14, 2013 6:16 pm, em um total de 1 vez.
Avatar do usuário
André Luiz
Colaborador Intermediario Mageia
Colaborador Intermediario Mageia
 
Mensagens: 88
Registrado em: Dom Abr 21, 2013 8:43 pm

Re: Wine não instala direito no Mageia3 64 bits!

Mensagempor macxi » Sáb Nov 16, 2013 2:44 pm

Pelo que vi, parece que so falta as mídas "Tainted release" e "Tainted Updated".

Image

Aqui o Wine32 instalou semp problema no Mageia 3, 64 bits.
Avatar do usuário
macxi
Suporte Wiki Mageia Brasil
Suporte Wiki Mageia Brasil
 
Mensagens: 1535
Registrado em: Qua Abr 17, 2013 10:09 pm

Re: Wine não instala direito no Mageia3 64 bits![RESOLVIDO]

Mensagempor André Luiz » Dom Nov 24, 2013 12:33 pm

Pessoal,
'Update' (sem trocadilho! :mrgreen: ) do problema: seguindo conselhos dos amigos, e em especial as orientações de meu 'guru Linux', meu amigo Fessel, revisei as mídias habilitadas (anexo, como ficou -- mantive habilitadas as mídias 'Testing' e 'Tainted', inclusive as 'updates'; deixei de fora somente as 'debug' )
De resto, tive que recorrer à "força bruta" -- comando no terminal mesmo... Um 'urpme --auto-orphans' aqui, 'urpmi -- update --auto-select' ali, e finalmente mandei atualizar tudo com 'urpmi --auto-select'; Selecionou bem uns 122 pacotes, que levou entre baixar e instalar coisa de 5 min (bendita hora que troquei de provedor de banda larga! :) ) Consegui atualizar o kernel para o 3.10.19, sugerido pelo Fessel, e após reiniciar ,o MCC selecionou corretamente o wine64 (com o pacote wine32 também, automaticamente)! Rodou de boa, e o wine já está lá de volta no menu do lançador!

Então, dou o problema como 'RESOLVIDO'! :)

Abraços a todos!!
Anexos
Mídias_revisto2.png
Mídias_revisto.png
Avatar do usuário
André Luiz
Colaborador Intermediario Mageia
Colaborador Intermediario Mageia
 
Mensagens: 88
Registrado em: Dom Abr 21, 2013 8:43 pm


Voltar para Jogos e Entretenimentos

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante

cron